summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..4139418
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(TEST_SRC_LIST
+ main.cpp
+ utils.cpp
+ tgbot/net/Url.cpp
+ tgbot/net/HttpParser.cpp
+ tgbot/tools/StringTools.cpp
+)
+
+include_directories("${PROJECT_SOURCE_DIR}/test")
+add_executable(${PROJECT_NAME}_test ${TEST_SRC_LIST})
+target_link_libraries(${PROJECT_NAME}_test TgBot)
+add_test(${PROJECT_NAME}_test ${PROJECT_NAME}_test) \ No newline at end of file