summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Pugin <egor.pugin@gmail.com>2020-03-15 14:43:58 +0300
committerEgor Pugin <egor.pugin@gmail.com>2020-03-15 14:43:58 +0300
commit16c9b77ee88dcfa131e14643eb5889e8cf770ce9 (patch)
tree42afa5cd4245b64f16f936491d374dadabddd41c /CMakeLists.txt
parenta1acba9a850cf80cf645756dd938940beafa57e7 (diff)
Bump minimal C++ to C++14.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 964d70a..d8a02b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,11 +6,11 @@ option(ENABLE_TESTS "Set to ON to enable building of tests" OFF)
option(BUILD_SHARED_LIBS "Build tgbot-cpp shared/static library." OFF)
# sources
+set(CMAKE_CXX_STANDARD 14)
if(WIN32)
set(CMAKE_WINDOWS_EXPORT_ALL_SYMBOLS ON)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
endif()
include_directories(include)