summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTransporter <ogre.transporter@gmail.com>2020-04-30 19:25:47 +0200
committerTransporter <ogre.transporter@gmail.com>2020-04-30 19:25:47 +0200
commit53e5e8cb0143736eb69820220a220a72cdd616de (patch)
treefba018e2f6d5405d2996a9896a45e44621cbc0ef /CMakeLists.txt
parentc378b6fb97a30175e957c8ce0bd8ad7bf5bcbe7f (diff)
Fix issure #138: DLL export fails
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6587a48..4d916f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,3 +88,7 @@ if (ENABLE_TESTS)
enable_testing()
add_subdirectory(test)
endif()
+
+if(MSVC AND BUILD_SHARED_LIBS)
+ add_definitions(-DTGBOT_DLL)
+endif() \ No newline at end of file