summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorllnulldisk <48621230+llnulldisk@users.noreply.github.com>2022-09-30 17:46:58 +0200
committerllnulldisk <48621230+llnulldisk@users.noreply.github.com>2022-09-30 17:46:58 +0200
commit70b02c460b55f6a6722a852704ee7d916c48ed47 (patch)
tree6b9134d703edcc2e173ad3218daac1b3ecd4e6a1 /CMakeLists.txt
parentd9dfa73edda127580e0961c89d8fafa56735f672 (diff)
Update docker files and CMakeLists
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 664bf67..b2a2b09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8.12)
+cmake_minimum_required(VERSION 3.13.4)
project(TgBot)
# options
@@ -51,7 +51,7 @@ find_package(OpenSSL REQUIRED)
include_directories(${OPENSSL_INCLUDE_DIR})
## curl
-find_package(CURL 7.56.0)
+find_package(CURL 7.64.0)
if (CURL_FOUND)
include_directories(${CURL_INCLUDE_DIRS})
add_definitions(-DHAVE_CURL)
@@ -60,9 +60,9 @@ endif()
## boost
set(Boost_USE_MULTITHREADED ON)
if (ENABLE_TESTS)
- find_package(Boost 1.59.0 COMPONENTS system unit_test_framework REQUIRED)
+ find_package(Boost 1.67.0 COMPONENTS system unit_test_framework REQUIRED)
else()
- find_package(Boost 1.59.0 COMPONENTS system REQUIRED)
+ find_package(Boost 1.67.0 COMPONENTS system REQUIRED)
endif()
include_directories(${Boost_INCLUDE_DIR})
link_directories(${Boost_LIBRARY_DIR_RELEASE})