summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorasapelkin <kotofey93@gmail.com>2017-01-16 10:45:44 +0400
committerGitHub <noreply@github.com>2017-01-16 10:45:44 +0400
commit798a7a60287012338b1b42b88e4c8d3fdc3c2eb0 (patch)
treea3b6b6384fdaf8095dca4fdc47935f2233da4e6c /CMakeLists.txt
parentd03eda27cdbe75470068d7513ecf510d8d342cf5 (diff)
Specified minimum version of Boost.
Specified minimum version of Boost (boost::property_tree::read_json don't work with cyrillic correctly in Boost lower 1.59)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9acb2f0..e25e560 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,9 +29,9 @@ include_directories(${OPENSSL_INCLUDE_DIR})
# boost
set(Boost_USE_MULTITHREADED ON)
if (ENABLE_TESTS)
- find_package(Boost COMPONENTS system iostreams unit_test_framework REQUIRED)
+ find_package(Boost 1.59.0 COMPONENTS system iostreams unit_test_framework REQUIRED)
else()
- find_package(Boost COMPONENTS system iostreams REQUIRED)
+ find_package(Boost 1.59.0 COMPONENTS system iostreams REQUIRED)
endif()
include_directories(${Boost_INCLUDE_DIR})