summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOleg Morozenkov <m@oleg.rocks>2019-06-29 03:15:16 +0300
committerGitHub <noreply@github.com>2019-06-29 03:15:16 +0300
commit89ec4e3d1186e1a250adb18cb6a8cce7c4756bf6 (patch)
treebfd72d91e25e8ef6c3dd421ceb991ad04bbefb28 /CMakeLists.txt
parent76fb029bc1b8ec6a7fd86cb9b62aa267cb9dd99c (diff)
parentcb67f11d8e1c67cdd8de8f47e6e42eba89324858 (diff)
Merge pull request #105 from dasys-lab/master
added -fPIC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 290c91c..275c505 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,7 @@ install(TARGETS ${PROJECT_NAME}
LIBRARY DESTINATION lib
ARCHIVE DESTINATION lib)
install(DIRECTORY include/ DESTINATION include)
+set_property(TARGET ${PROJECT_NAME} PROPERTY POSITION_INDEPENDENT_CODE ON)
# tests
if (ENABLE_TESTS)