summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOleg Morozenkov <omorozenkov@gmail.com>2018-06-22 23:23:00 +0300
committerGitHub <noreply@github.com>2018-06-22 23:23:00 +0300
commitf31df3f057c81aec138d2e0cb09079a6ec57fc43 (patch)
tree7316a800504882fcc36ca5c61d8128c89c5d4eb5 /CMakeLists.txt
parenta854dd975f13e71338c80d85717be6fb6e8c185a (diff)
parentacbb803e4c245e70d75587a7491995e88320324e (diff)
Merge pull request #69 from JellyBrick/master
Bot API 3.0 implementation done. / Support build shared library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89ea260..f5ff1d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,7 @@ project(TgBot)
### options
option(ENABLE_TESTS "Set to ON to enable building of tests" OFF)
+option(BUILD_SHARED_LIBS "Build tgbot-cpp shared/static library." OFF)
### sources
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")