summaryrefslogtreecommitdiff
path: root/samples/echobot-setmycommands/CMakeLists.txt
diff options
context:
space:
mode:
authorOleg Morozenkov <m@oleg.rocks>2020-08-21 01:41:36 +0300
committerGitHub <noreply@github.com>2020-08-21 01:41:36 +0300
commit4009b7ea603dcd7f21c6e852497daba7b0a1a6b3 (patch)
tree6dd10e3c92accb9aa250bc30862a59f6f7d9067b /samples/echobot-setmycommands/CMakeLists.txt
parent3230b1b5d84a7a948324949eb607082dc40fe01e (diff)
parentffc3c38882d669ea6b2abeea5c0f7c7b322fa6e7 (diff)
Merge pull request #143 from sebest06/master
* add SetMyCommand to the api
Diffstat (limited to 'samples/echobot-setmycommands/CMakeLists.txt')
-rw-r--r--samples/echobot-setmycommands/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/samples/echobot-setmycommands/CMakeLists.txt b/samples/echobot-setmycommands/CMakeLists.txt
new file mode 100644
index 0000000..7019e8f
--- /dev/null
+++ b/samples/echobot-setmycommands/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 2.8.4)
+project(echobot)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
+set(Boost_USE_MULTITHREADED ON)
+
+find_package(Threads REQUIRED)
+find_package(OpenSSL REQUIRED)
+find_package(Boost COMPONENTS system REQUIRED)
+find_package(CURL)
+include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+if (CURL_FOUND)
+ include_directories(${CURL_INCLUDE_DIRS})
+ add_definitions(-DHAVE_CURL)
+endif()
+
+add_executable(echobot src/main.cpp)
+
+target_link_libraries(echobot /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES} ${CURL_LIBRARIES})