summaryrefslogtreecommitdiff
path: root/samples/echobot/CMakeLists.txt
diff options
context:
space:
mode:
authorEgor Pugin <egor.pugin@gmail.com>2018-07-04 19:37:55 +0300
committerEgor Pugin <egor.pugin@gmail.com>2018-07-04 19:37:55 +0300
commit6f8519027d135d440ba13aff0842d0cd0131d7d5 (patch)
tree356216ce973fab8ddcd5a5123e5cb326ab1486e0 /samples/echobot/CMakeLists.txt
parentac3e87822afb6065a82dfe547ecbc0c307a04147 (diff)
Fix examples.
Diffstat (limited to 'samples/echobot/CMakeLists.txt')
-rw-r--r--samples/echobot/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/samples/echobot/CMakeLists.txt b/samples/echobot/CMakeLists.txt
index d67f4d4..0639d66 100644
--- a/samples/echobot/CMakeLists.txt
+++ b/samples/echobot/CMakeLists.txt
@@ -7,8 +7,13 @@ set(Boost_USE_MULTITHREADED ON)
find_package(Threads REQUIRED)
find_package(OpenSSL REQUIRED)
find_package(Boost COMPONENTS system REQUIRED)
+find_package(CURL)
include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+if (CURL_FOUND)
+include_directories(${CURL_INCLUDE_DIRS})
+add_definitions(-DHAVE_CURL)
+endif()
add_executable(echobot src/main.cpp)
-target_link_libraries(echobot /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES})
+target_link_libraries(echobot /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES} ${CURL_LIBRARIES})