summaryrefslogtreecommitdiff
path: root/samples/echobot/CMakeLists.txt
diff options
context:
space:
mode:
authorOleg Morozenkov <reo7sp@users.noreply.github.com>2017-01-26 00:32:22 +0300
committerOleg Morozenkov <reo7sp@users.noreply.github.com>2017-01-26 00:32:22 +0300
commit85e0e991973594fb458410876a1cc09c5971b918 (patch)
tree08186c9e9f58cdb617b9b63d583f535b1c884b72 /samples/echobot/CMakeLists.txt
parent3549754e53f79e9ba0b00fb0bbded5d56a14ef51 (diff)
Helper method for loading files. Photo upload example. Fixes #24
Diffstat (limited to 'samples/echobot/CMakeLists.txt')
-rw-r--r--samples/echobot/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/samples/echobot/CMakeLists.txt b/samples/echobot/CMakeLists.txt
index c54109c..5df19f7 100644
--- a/samples/echobot/CMakeLists.txt
+++ b/samples/echobot/CMakeLists.txt
@@ -1,10 +1,14 @@
cmake_minimum_required(VERSION 2.8.4)
project(echobot)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
set(Boost_USE_MULTITHREADED ON)
+
find_package(Threads REQUIRED)
find_package(OpenSSL REQUIRED)
-find_package(Boost COMPONENTS system iostreams unit_test_framework REQUIRED)
+find_package(Boost COMPONENTS system iostreams REQUIRED)
include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+
add_executable(echobot src/main.cpp)
+
target_link_libraries(echobot /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES})