summaryrefslogtreecommitdiff
path: root/samples/echobot/CMakeLists.txt
diff options
context:
space:
mode:
authorOleg Morozenkov <omorozenkov@gmail.com>2015-08-12 19:59:52 +0300
committerOleg Morozenkov <omorozenkov@gmail.com>2015-08-12 20:00:20 +0300
commit88b945b907eee025e33b259c95a61c7fe5d213c0 (patch)
tree9d9a928155da4d5351fb143bc8b6489f9bfca0bd /samples/echobot/CMakeLists.txt
parentf94a2dd6c2832c6ba0379d4c8eec367b25a4a2e2 (diff)
Make the samples independent of the library's CMakeLists
Diffstat (limited to 'samples/echobot/CMakeLists.txt')
-rw-r--r--samples/echobot/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/samples/echobot/CMakeLists.txt b/samples/echobot/CMakeLists.txt
index c8c02ea..c54109c 100644
--- a/samples/echobot/CMakeLists.txt
+++ b/samples/echobot/CMakeLists.txt
@@ -1,4 +1,10 @@
-set(SAMPLE_NAME echobot)
-
-add_executable(${SAMPLE_NAME} src/main.cpp)
-target_link_libraries(${SAMPLE_NAME} TgBot) \ No newline at end of file
+cmake_minimum_required(VERSION 2.8.4)
+project(echobot)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+set(Boost_USE_MULTITHREADED ON)
+find_package(Threads REQUIRED)
+find_package(OpenSSL REQUIRED)
+find_package(Boost COMPONENTS system iostreams unit_test_framework REQUIRED)
+include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+add_executable(echobot src/main.cpp)
+target_link_libraries(echobot /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES})