summaryrefslogtreecommitdiff
path: root/samples/inline-keyboard/CMakeLists.txt
diff options
context:
space:
mode:
authorOleg Morozenkov <reo7sp@users.noreply.github.com>2017-01-02 22:34:14 +0300
committerOleg Morozenkov <reo7sp@users.noreply.github.com>2017-01-02 22:34:14 +0300
commitd578d8be57e80d8ca05ad1bd936eb4936bd87d9d (patch)
tree66287d801a087caf7cc3965bf14f99d598b38dbe /samples/inline-keyboard/CMakeLists.txt
parent8ee17005234d535ef3d311817ad23992fb9932f2 (diff)
Inline keyboard sample
Diffstat (limited to 'samples/inline-keyboard/CMakeLists.txt')
-rw-r--r--samples/inline-keyboard/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/samples/inline-keyboard/CMakeLists.txt b/samples/inline-keyboard/CMakeLists.txt
new file mode 100644
index 0000000..c59a97a
--- /dev/null
+++ b/samples/inline-keyboard/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 2.8.4)
+project(inline-keyboard)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+set(Boost_USE_MULTITHREADED ON)
+find_package(Threads REQUIRED)
+find_package(OpenSSL REQUIRED)
+find_package(Boost COMPONENTS system iostreams unit_test_framework REQUIRED)
+include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+add_executable(inline-keyboard src/main.cpp)
+target_link_libraries(inline-keyboard /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES})