summaryrefslogtreecommitdiff
path: root/samples/reply-keyboard/CMakeLists.txt
diff options
context:
space:
mode:
authorllnulldisk <48621230+llnulldisk@users.noreply.github.com>2022-09-30 17:46:58 +0200
committerllnulldisk <48621230+llnulldisk@users.noreply.github.com>2022-09-30 17:46:58 +0200
commit70b02c460b55f6a6722a852704ee7d916c48ed47 (patch)
tree6b9134d703edcc2e173ad3218daac1b3ecd4e6a1 /samples/reply-keyboard/CMakeLists.txt
parentd9dfa73edda127580e0961c89d8fafa56735f672 (diff)
Update docker files and CMakeLists
Diffstat (limited to 'samples/reply-keyboard/CMakeLists.txt')
-rw-r--r--samples/reply-keyboard/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/samples/reply-keyboard/CMakeLists.txt b/samples/reply-keyboard/CMakeLists.txt
new file mode 100644
index 0000000..845b038
--- /dev/null
+++ b/samples/reply-keyboard/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 3.13.4)
+project(reply-keyboard)
+
+set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
+set(Boost_USE_MULTITHREADED ON)
+
+find_package(Threads REQUIRED)
+find_package(OpenSSL REQUIRED)
+find_package(Boost COMPONENTS system REQUIRED)
+find_package(CURL)
+include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+if (CURL_FOUND)
+ include_directories(${CURL_INCLUDE_DIRS})
+ add_definitions(-DHAVE_CURL)
+endif()
+
+add_executable(reply-keyboard src/main.cpp)
+
+target_link_libraries(reply-keyboard /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES} ${CURL_LIBRARIES})