summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1759746..606c7de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,9 @@ install(TARGETS ${PROJECT_NAME}
install(DIRECTORY include/ DESTINATION include)
set_property(TARGET ${PROJECT_NAME} PROPERTY POSITION_INDEPENDENT_CODE ON)
+# ABI version
+set_property(TARGET ${PROJECT_NAME} PROPERTY SOVERSION 1)
+
# tests
if (ENABLE_TESTS)
message(STATUS "Building of tests is enabled")