summaryrefslogtreecommitdiff
path: root/samples/echobot-curl-client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'samples/echobot-curl-client/CMakeLists.txt')
-rw-r--r--samples/echobot-curl-client/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/samples/echobot-curl-client/CMakeLists.txt b/samples/echobot-curl-client/CMakeLists.txt
new file mode 100644
index 0000000..40e3200
--- /dev/null
+++ b/samples/echobot-curl-client/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.8.4)
+project(echobot-curl-client)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
+set(Boost_USE_MULTITHREADED ON)
+
+find_package(Threads REQUIRED)
+find_package(OpenSSL REQUIRED)
+find_package(Boost COMPONENTS system REQUIRED)
+find_package(CURL)
+include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR} ${CURL_INCLUDE_DIRS})
+add_definitions(-DHAVE_CURL)
+
+add_executable(echobot-curl-client src/main.cpp)
+
+target_link_libraries(echobot-curl-client /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES} ${CURL_LIBRARIES})