summaryrefslogtreecommitdiff
path: root/samples/echobot-setmycommands/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'samples/echobot-setmycommands/CMakeLists.txt')
-rw-r--r--samples/echobot-setmycommands/CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/samples/echobot-setmycommands/CMakeLists.txt b/samples/echobot-setmycommands/CMakeLists.txt
index 7019e8f..f8d4ad2 100644
--- a/samples/echobot-setmycommands/CMakeLists.txt
+++ b/samples/echobot-setmycommands/CMakeLists.txt
@@ -1,7 +1,9 @@
-cmake_minimum_required(VERSION 2.8.4)
-project(echobot)
+cmake_minimum_required(VERSION 3.10.2)
+project(echobot-setmycommands)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
+set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
set(Boost_USE_MULTITHREADED ON)
find_package(Threads REQUIRED)
@@ -14,6 +16,6 @@ if (CURL_FOUND)
add_definitions(-DHAVE_CURL)
endif()
-add_executable(echobot src/main.cpp)
+add_executable(echobot-setmycommands src/main.cpp)
-target_link_libraries(echobot /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES} ${CURL_LIBRARIES})
+target_link_libraries(echobot-setmycommands /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES} ${CURL_LIBRARIES})