summaryrefslogtreecommitdiff
path: root/samples/inline-keyboard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'samples/inline-keyboard/CMakeLists.txt')
-rw-r--r--samples/inline-keyboard/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/samples/inline-keyboard/CMakeLists.txt b/samples/inline-keyboard/CMakeLists.txt
index c59a97a..dbcff89 100644
--- a/samples/inline-keyboard/CMakeLists.txt
+++ b/samples/inline-keyboard/CMakeLists.txt
@@ -1,10 +1,14 @@
cmake_minimum_required(VERSION 2.8.4)
project(inline-keyboard)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
set(Boost_USE_MULTITHREADED ON)
+
find_package(Threads REQUIRED)
find_package(OpenSSL REQUIRED)
-find_package(Boost COMPONENTS system iostreams unit_test_framework REQUIRED)
+find_package(Boost COMPONENTS system iostreams REQUIRED)
include_directories(/usr/local/include ${OPENSSL_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
+
add_executable(inline-keyboard src/main.cpp)
+
target_link_libraries(inline-keyboard /usr/local/lib/libTgBot.a ${CMAKE_THREAD_LIBS_INIT} ${OPENSSL_LIBRARIES} ${Boost_LIBRARIES})